Back to overview
Downtime
The system is experiencing slower speeds than usual
Apr 21 at 07:25am BST
Affected services
Cinapsis
Resolved
Apr 21 at 11:37am BST
All issues with speed are now resolved.
Affected services
Created
Apr 21 at 07:25am BST
We want to clarify that users can still use the system but are experiencing slow speeds. We are still investigating to understand what is causing the performance issue and we will send an update shortly.
Affected services