Back to overview
Downtime
The system is currently down and this issue is being investigated
Jul 20 at 10:12am BST
Affected services
Cinapsis
Resolved
Jul 20 at 10:17am BST
The system is now back up and functional again. We apologise for the inconvenience this has caused.
Affected services
Created
Jul 20 at 10:12am BST
We are working on fixing this issue and will publish an update as soon as possible.
Affected services